CMS Nest + CMS Tabs + CMS Filter (Filter not working)


I have created a CMS filter to achieve the desired design, and future proofing with dynamic content on a project.

And when combining CMS Nest and CMS Tabs, the CMS Filter solution does not seem to work. I have tried the debugging link (?fs-attributes-support=true), but that says that i have set everything up with the CMS Filter.

The problem is probably with the Nested CMS, that only brings the relevant filters for that specific CMS Tab. This nesting moves the filters, and i think that is causing the problem… Maybe there is a way to reload the filter after the nesting on that specific page?

Is there a attribute expert here that could help out with this? Suggestions or solutions is highly appreciated!

Hello @dustin! The simplest solution is to call the init() function for CMS Filter after both CMS Nest and CMS Tabs have finished.

Please share a live link and I’ll provide the code needed to fix this :muscle:

1 Like

Hi, @Support-Luis

Thanks! I will share it with you directly if that is okay. I tried to send it as a message to you. Let me know if it did not reach you.