F'insweet Weglot language switcher won't work with hreflang language variants (nl-BE)

Hello F’insweet,

I’m trying to implement a Weglot localization with a hreflang=“nl-BE” attribute using your language switcher. Even though I set this as the basic language in my Weglot code and the F’insweet-based toggle button, it won’t change the language.

I’m not sure if this is a F’insweet or a Webflow issue, cause I can still see that the site language is nl in the project settings, even though I added a localization for the belgian variant, so the hreflang tag is set correctly.

I guess the F’insweet option is based on the general site lang=“nl” tag? I can’t seem to change it in the site settings.

Can you point me to any possible solutions?

Thanks a lot!


@Support-Luis could you have a look at this please? thank you

here’s the site, I even changed the general lang attribute to nl-BE (the weglot code and the finsweet switcher attribute is also set to nl-BE), but to no avail: https://valorservicesgroup.be/

Hey @de.skaaa! I’m afraid I can not offer Weglot support, you can keep the thread open in case anyone from the community has an answer to this issue. Have you reached out to Weglot’s support on this issue?

thanks @Support-Luis, I’m afraid this lays with the F’insweet switcher cause I can set up the hreflang tag in weglot and the site settings correctly, so everything should be running smoothly. but when I set the lang attribute to nl-BE (instead of nl) in the F’insweet switcher, it won’t switch to the proper translation.

do you know if your switcher and JS code supports language variants too? so not only nl, es, en, etc, but also belgian dutch, hong kong english, etc

nevertheless, I’ll contact Weglot but I suspect that they’ll point back to you

@de.skaaa could you point me to witch language switcher and code you are referring to? I am afraid I have not seen this before, but anyway, if Weglot supports language variants I don’t see why the switch would fail