Table of Contents working on Desktop, but not Mobile

I’m using Table of Contents and it’s working fine on desktop but not on mobile.


Preview: Webflow - ToC Testing

I put the fs-toc-element=“link” attr on the heading in this example. When using the attributes debugger it said I should move it to link block element (which is against what the documentation says).

Anyway, I tried moving the fs-toc-element=“link” attribute from the heading div to the link block div but that didn’t work either.

A client of mine is having the same issue on a different project.

I’m viewing on mobile with iPhone, chrome browser. I loaded up Safari because I can inspect console from my Macbook there and get this error:

Unhandled Promise Rejection: TypeError: undefined is not an object (evaluating 't[r].closest')

1 Like

hey @leary.keegan! I can’t seem to replicate this issue. Can you please share a recording or image on how to get this error?

Hi @Support-Luis :wave: I’m also noticed, that on Mobile (device) ToC is not works (just showing first element):

Hey! Which iOS are you on? I am testing on iOS 16 and both Safari and Chrome are working as expected


I am updating at the moment! I’ll report back!

Found this forum post as I’m having the same issue right now. I cannot replicate the issue on my end (or anyone else I’ve asked), but the client consistently sees a broken TOC. Any update here on what could be causing this on mobile and not desktop?

1 Like

Hey @hello18! No update at the moment. The ticket is still open

Same here, it is working on Chromium browser but not on safari even on desktop

I am also having this issue of the ToC not working on touch screen devices. It only shows the first H2

@Support-Luis I also get a weird scroll effect happening on mobile for table of contents attribute:

You can [see the video here]

See [read-only link here]

hey @hello8! Is this also on iOS 17?

iOS 16.6.1 @Support-Luis

Live link

@hello8, a fix has been pushed last week. Can you let me know if this issue still persists?

Hi @Support-Luis ,

I have the same issue too between links not being displayed in Safari.

I have even tried it with the Finsweet demo page with instructions and I got a different version too between Chrome and Safari., is this also on mobile?

Hi @Support-Luis , yes. can you share a link?

I’m encountering a similar issue on both my laptop and mobile devices. Specifically, certain items in the Table of Contents are not displaying when I use Safari.

Any updates on this matter?
Thanks in advance!

@Support-Luis just making sure you see this :slight_smile: sorry to bother