Lockfile error when pushing my code to NPM

[SOLVED] Hey all !
I’m working with Finsweet Developer Starter and I’m having an error on Github since today when I tried to push my code to NPM with the “changeset” command.

You can see the error message on the screenshots.
It seems that my last “pnpm install” command created an error with the pnpm-lock.yaml file.
I tried the command “pnpm install --no-frozen-lockfile” and then a “changeset” command but the error keeps showing in Github.

I tried with another project working great today that I pushed a few hours ago. I opened it again, ran pnpm install, ran pnpm changeset, and then the error appears on Github. No update to my code except the “pnpm install” command.

There is something wrong and I can’t figure it out.
Thanks for your help.

Update :
I tried with a brand new cloned FDS Repo, ran pnpm install then changeset.
Got the same error on Github :

SOLVED : PNPM was updated to version 9.
FDS isn’t ready yet for this version.

I downgraded to version 8 with this command pnpm add -g pnpm@8 thanks to Alex Iglesias and now everything is working fine !

1 Like

Thanks for sharing the solution @rolandtheo!