CMS Filter/Nest Not Including All Items

Hi! I am having an issue with the nested items. I cannot tell if the issue is with the filter or the nesting. If you take a look at the page and click on any of the Style dropdowns, you will get a list of the “Historic” “Traditional” and “Modern” styles. Whats strange is all of the styles work as long as they start with the letters between “I” and “Z” anything before that doesn’t show anything. In the collection template, it shows all of the styles correctly. Not sure whats going on, wondering if i could get some assistance. Thank you!

Update: I am realizing that most of the filters are not accurate. It doesn’t seem to be properly pulling from the template page.

Hey @helixmediax! Can er try adding a CMS Load instance with render-all to your style filters?

If you add this code to your page you can see in the logs how every other filter category has at least one result in the elements array… this makes me think this is not fully loaded on the page and something weird is happening

      window.fsAttributes = window.fsAttributes || [];
        (filterInstances) => {
          console.log('cmsfilter Successfully loaded!');

          // The callback passes a `filterInstances` array with all the `CMSFilters` instances on the page.
          const [filterInstance] = filterInstances;
          // The `renderitems` event runs whenever the list renders items after filtering.
          filterInstance.listInstance.on('renderitems', (renderedItems) => {


Update. I duplicated the page and tried to see how everything loaded if i turned off fs load and it loaded everything right away. It seems that the issue is with the FS load and not with webflow or additional code on t he page.

Hey @helixmediax, I meant you to apply the CMS Load setup to your filter collection as the render-all option can impact load times as described in the documentation. But disregard that suggestion, your video shows it is not the filter collection that ic causing the issues.

I remember you were using the load-under option before. Have you tried activating the speed boost?

This happens because CMS Nest requests info from the template page for each item upon the first page load, this is not needed for future loads as the info is stored in the user’s cache which expires on next page publish.

You could look into the second option for CMS Nest which bypasses all these requests, this option does require some manual data entry and additional elements but has proved successful in improving load times.

Hey Luis, so thats what i thought as well (saved in the cache). But i found that it still takes a while for it to load in those images even when its been done before. Is there no fix on yalls end? The issue for me is that it was working perfectly not too long ago (with the nesting) but it recently started having these issues.

Ok so it looks like it is working now, im not sure if it was my end or yall. But ill keep ya posted. Thanks again!

Nvm, it was working for a few but then it started messing up again.

Also, i cannot do the manual process.

Hi, Have yall found a fix for the Finsweet Nest?

Can Someone please help me? The only alternative I see is to switch to Jetboost. The issue becomes corrected when i remove the Finsweet Nest Code. I cannot enter the info manually. I do not know of any other options. I have been working specifically with Finsweet on all of my projects and I spent money to join these Forums to get these issues resolved. Please Help