Fin CMS Nest Broken? Please Help

I’ve been building this site for quite some time now and the filter system has been working perfectly. I just tried it again after a bit of time and it just isn’t working. It’s particularly the Finsweet CMS Nest that isn’t working. Everything else seems to work except for the nested collection. The collection does nest but it isn’t pulling the mapped reference fields from the template page, so its just using every collection item in the template. I’ve even gone through and copied everything i could from the clonable from them and still nothing. I ran the “?fs-attributes-support=true” test and it tells me that the template page doesn’t have a link for the items, but it does. This is the message i get “The attribute fs-cmsnest-collection=“nationality” is found on the Collection’s Template page, but is missing the url link to each item. Add a Link Block or Text Link inside the Collection Item on the CMS Template page.”. What drives me crazy is that it works perfectly on the clonable when i publish it. But I have everything set up exactly the same. If someone could please help id greatly appreciate it. Thank you

Template Page Share Link: Webflow - Artisynth

Here is my site Read-Only:Webflow - Artisynth

Hey @helixmediax! You seem to be missing a link to the current item in your collection, it is recommended this element be the first element of your collection item. You can use a hidden text link as shown in the image below.

Awesomesauce!! Thank you so much Luis!! Idk where i missed this in the tutorials but ill definitely remember it now lol.