CMS Nest issue - Collection "not found" on template page

Hi Finsweet

I’m running de Finsweet debugging tool on a basic nesting attribute. It keeps telling me:

“The Collection List on the Collection Template page is not found. Add a “foto-tags” Collection List on the primary content Collection template page. Add the attribute fs-cmsnest-collection=“foto-tags” to the Collection List element.”

I checked it multiple times, it IS there. I went through all steps 4 times and should be correct.

Read only link: Webflow - Exstatic

Hey @matthias1! The issue might be in the link placement. Can you please move the link to be a direct child to the collection list item?

Hi @Support-Luis

Doesn’t seem to change anything, I moved all the links like you said to be the direct child of the collection list item

hey @matthias1! I see you do not have the CMS Nest script added to your page settings, have you added it to your project settings?

Hi @Support-Luis

Yes it was added globally :slight_smile:

Hey @matthias1! I see the fs-cmsnest-collection = foto-tags attribute on your source list is not being published. This is because you have a space at the beginning of the attribute name. Can you please correct and let me know so I can go back and look at it?

Hi @Support-Luis

I’ve checked all attributes and I don’t see a space anywhere in webflow, I’ve retyped them by hand to make sure no spaces are there…

Here is the extra space I was mentioning, this prevents the Attribute from showing on the published page.

I added it locally and the list is nesting as expected

Oh wow, I really didn’t see that one. You’re a legend Luis, thank you!

1 Like

You are welcome Matthias! :muscle: