Finsweet Filter - only one select field is not working, the rest works fine

Share Link

webflow.io link

Only the service select field is not working, tried changing the value for fs-cmsfilter-field, did not work, tried using fs cms nest though i do not need it, still did not work.

May I know what I need to do to make the Service select field work with fs filter? the Region select field works fine.

Hey @miko! Everything seems to be set correctly. The values are matching correctly to the text inside the item.

Even changing the text input to target the field returns no results… Let me check with the team on this one. I’ll get back to you

@Support-Luis Thank you for looking into this, will wait for your response. Me and a colleague have tried reviewing it also and we also do not know why the Service select field is not working.

I’ve got another pair of eyes helping me debug. We’ll let you know if we find any issue :muscle:

Hey @miko! It seems that Webflow’s native nest is causing the issue.

Can you please try setting up the CMS Nest? I see you have the script on the page but no element has the needed attributes. If you have any issues setting it up let me know

@Support-Luis it is now using CMS nest, links are the same

Perfect @miko, I see them nesting accordingly. However seems the corresponding attributes are not being correctly added. This might be from directly hiding the nested collection on the designer. You can wrap it with a div and set it to display: none or let it be. The script will hide it anyway.

This should get the filter working as expected

@Support-Luis it is not hidden on the published link, but i have removed the hide class name on the preview link too and republished. sadly, still not filtering…

I can see, we are taking another look now.

@Support-Luis Any update on this?

Hey @miko, I’ve been going over and over the setup and everything is as it should.

Could we make some modifications to test? Can you please remove the service select and add a couple of radio buttons with some of the categories?

@Support-Luis removed select field and changed it with 3 radio buttons under the radio group Radio for test. The links are the same. weirdly, even radio buttons are affected. it is not filtering.

@miko Sorry for bringing you back and forth. First time CMS Filter has acted this way. Is there any chance you could rebuild this page from scratch? With the CMS Nest setup and a different identifier for the service filter (instead of 1234 user service)?

@Support-Luis Sorry for the delay, discussing with the team if rebuilding the page is an option. Will advise as soon as possible if I can do that.

No worries, let me know whatever you proceed on doing.