Problem with CMS Combine + CMS Sort past 100 items

Hello everyone,

I have this urgent problem on a website for my client.

Here’s the read only link:

And live link :

As you can see, in order to display all the results on one page, we are using CMS combine. There are 3 collection lists combined because they have around 250 listings on the page.

They want to have a sort button to be able to sort from highest / lowest price and newest / oldest.

When you start sorting by price, it only sorts the first 100 items and then when you reach the 101st item, it’s sorting but within that second collection list, not globally across all items.

I actually don’t know if it does that regarding the sorting from newest / oldest, but there might be the same problem.

Could you please help me solve this problem? It’s been giving me a headache for some time now…

Hey @hello5! When you combine lists there is no need to add CMS Sort, CMS Filter or CMS Load attributes to all lists. Only the first list having these attributes should be fine to make it work as intended.

Can you please try this approach and let me know if this works?

Hello Luis,
I tried to do that on a copy of the website not to mess everything up. Here’s the read only link : Webflow - Copy for testing

And the live site: Browse All Property Listings - Exotiq Property

I removed all custom attributes on the second and third collection lists (except combine) but it doesn’t seem to work. As you can see on this picture, I sorted by the highest price, and the 101th listing has a higher price than the 100th

If we scroll down a bit more, we reach the 3rd list and same thing:

And it seems that they are not even sorted in the 2nd and 3rd collections. On the contrary, when I had the custom attributes also on those lists, it was at least sorting in each list.

@hello5 you are missing the CMS Load script and your load mode.

You can find both here. I added the script and set render-all as the load mode and the items seem to sort as expected.

ok, I just added the CMS load + the render-all attribute but it’s still not working.

I scrolled under up to the last item of the first collection and then again there’s a difference between listings prices:

Here the last item of the first list is 400 million and the first item of the second list is 400 billion roupiah.

Even on your screenshot. It looks like it’s working but the highest price is higher than 99b roupiah.

I think the problem here is because the combined CMS collections are the same collection. The first goal was to render all items in the CMS collection list. Which was not possible natively in Webflow. (And I actually didn’t know about the CMS load / render-all.)

One problem with this option is that if I enable the pagination for the first collection, and add ‘render-all’ it is going to create duplicates since they are all the same collections…

So I also tried removing the second and third list and not use ‘cms combine’ but it clashes with the multi-currency third party (monto). The latter does not recognize the items to be loaded, so it does not make the translation of the currency… and this is crucial for the sorting to work…

I’m lost in what I need to do here…


I manage to make the previous solution work (CMS combine) and I checked all my attributes. In the confusion with all my trials and errors, I forgot to add the finsweet attribute to the price element. But there are still a few items that come at the top for when sorting by highest price…

It’s really strange. On some browsers and devices, it works perfectly. The highest item is 411B roupiah.

But on my browser (arc, which is using chromium, and on iPhone) it doesn’t fully work. There are 5 items that ALWAYS come on top and break the sorting… Even after clearing the cache, it still doesn’t work properly.

On the browser I tested and it worked, I tried to open a new tab and sort and that’s where the problem appears… Any chance it has to do with some session storage?

My read only link

The live site: Browse All Property Listings - Exotiq Property?

Hey, @hello5 session storage shouldn’t be an issue with this combination of attributes.

It also seems to be working on my end. Let me know if you run into more issues