I don’t know if this is a valuable post, but I’m struggling with naming a specific thing. I’ve reviewed the Core Structure > section_[section-identifier] Docs and I’m still not sure if I’m overthinking this element.
Right now the element is called
.section_container and its purpose is to be the container/wrapper/background of almost every section, to avoid recreating this look for every
.section_ since it’d be redundant.
.background-color-[identifier] wouldn’t be useful cause there’s so much more to it than just changing the color. It’s transparent, it has a blur, it has shadows, and when the user swaps to dark mode, it gets the class
So that’s where my brain just stops. Does anyone have any suggestions on what to call it? Or should I just leave it as
Hello @Keithen , here are a few suggestion from chatGPT
.section_background: This name emphasizes the element’s purpose as a background container for sections. It retains the original naming convention but adds clarity.
.section_wrapper: This name suggests that the element serves as a wrapper around sections. It implies that it provides a common structure or layout for multiple sections.
.section_overlay: If the element has a transparent or semi-transparent background with blur and shadows, this name could reflect its overlay-like appearance.
.section_themeable: This name suggests that the element is designed to be easily customized or themed based on color schemes, modes, and other visual attributes.
.section_frame: This name conveys the idea of the element as a frame or border that surrounds and enhances the sections it contains.
This are all perfect! Thank you for the suggestions and help, it has been beautiful!