CMS Load - Page dots

Hi,

I’ve implemented CMS load and I’m trying to keep the number of shown page buttons, within the pagination div, to a certain maximum so that the pagination will be on the same line. I’m trying to do this with the page-siblings option and the page-boundary option. The guide explains the following:

Page dots are added to the page when there are more pages in your pagination than the total sibling pages + the total boundary pages + the current active page. Dots show and hide intelligently based on the pages in your pagination.

So I have six pages in total. To test the behavior of the page dots I set the page-siblings option and the page-boundary option to 1 and there is 1 current page. Then I would assume that the pagination would look something like this if I’m on the fourth page:

1 … 4 … 6

But my pagination section looks like this:

How can I limit the page buttons in the pagination?

https://preview.webflow.com/preview/eebel?utm_medium=preview_link&utm_source=designer&utm_content=eebel&preview=c561a057c1882639cf396da078822df9&pageId=64f9bd1246e31c40a020ee9f&workflow=preview

Kind regards,

Rémon

Hello @remonw! It seems you are missing your page-dots element, a <div>...</div> with the attribute fs-cmsload-element=page-dots should be enough.

Please test it and let me know how it goes.

Hi @Support-Luis,

It doesn’t make a difference, unfortunately. The docs describe this option as optional; if it’s not set, it will fall back to the <div>...</div>. So shouldn’t this be the default already?

It should, however, I wanted to double-check with you as this seems to be a new issue. I’ll look with the team and get back to you!

Hi @Support-Luis,

Do you know more about this issue?

Hey @remonw, it seems that these settings are content-dependent, as you can see below, the settings take effect when we have more pages.

We can set the page siblings to 0 to achieve the design you are after but this will cause some pages not to be correctly shown on the pagination