Issues when elements linked to CMS data

Hello everyone,

I have been stuck for six months with this issue (did not manage to get an answer on Slack and was too lazy to post on the forum).

Issues when elements linked to CMS data

Table of contents

With static text, my Table of Contents works:

With Dynamic text, it does not:

And here is the issue in video (from 4 months ago so the design is a bit different as I made my website leaner):

Powerful rich text

With static text, it works:

With dynamic text (synced from a Notion field containing html), it does not:

Help needed

I need help solving this, I tried deleting the entire page and recreating it.


Important points :

  • At some point, it worked, and than it did not without me changing anything on the page.
  • I thought it could be some minification from semrush messing up but the issue is the same on the staging site.
  • I have no other code running in the page:

Thank you for your help,

So actually it seems to be working on some articles and not others … in the same collection!



Anyone have any idea about this?
For HTML in rich text I added my own snippet for now but the ToC remains broken.
Thank you

Thanks to Michael Wells, it’s fixed!

hey @brindeau.joachim! I am sorry for not getting back yo you last week! We were on a retreat, I am really glad you got this working! :muscle: