Table of contents not showing current color after mouse click

Hello,
when I click a link in the table of contents the current color is not showing or another link has the current color. How can I fix it?

Read-only link
https://preview.webflow.com/preview/manual-3?utm_medium=preview_link&utm_source=designer&utm_content=manual-3&preview=f7f6dae49c06b7ec0b0e4578adb6b913&workflow=preview

Preview link
https://manual-3.webflow.io

Thanks a lot for your help!
Arne

hey @arnesaenger! This could be from your fs-toc-offsettop="6rem". You can reduce the value until the active state is applied to the link with the desired spacing from the top.

Hey @Support-Luis, Thanks a lot for your help. I tried to change the rem number but the problem still exists. I also tried to remove fs-toc-offsettop but its still not working correctly. Do you have any other idea what might be the problem? Thanks a lot!

Hey @arnesaenger, I’m almost 100% sure the issue is within an offset option.

Will you be adding a navbar to the site?

Hello @Support-Luis, I just created a new webpage and copied the example from the Finsweet Attributes website (without adding offset). I noticed that a link always gets coloured as current when the headline is in the middle of the screen but when I click a link the headline scrolls to the top of the screen. I think these two positions might cause the problem i am having. Can I change the position, at where a link gets coloured as current? I recorded the following screen video:

Screen video:

Read-only link of the example:
https://preview.webflow.com/preview/manual-7?utm_medium=preview_link&utm_source=designer&utm_content=manual-7&preview=309af7365ff88d67746308759c326a86&workflow=preview

Preview link:
https://manual-7.webflow.io

I am not sure yet if I will add a navbar to the site. Thanks again for your help!!!

Hey @arnesaenger, I’ve been playing around with different settings but I am afraid we can not modify this setting. We can only modify how the content behaves when a link is clicked.

I can submit a feature request but I would not have a ETA for this update

Hey @Support-Luis, if you could submit a feature request, that would be awesome. Thanks again for your help!

1 Like

I’ve created the feature request